Xrm.WebApi. “The query parameter $select is not supported” error.

By Olena Grischenko

Don’t be like me! This is the JavaScript: var uriClientLegacy = “?$select = cca_legacyservicefee, defaultpricelevelid & $filter=accountid eq ” + clientLookupId; Xrm.WebApi.retrieveMultipleRecords(“account”, uriClientLegacy).then( function success(result) { … }, function (error) { console.log(error.message); // handle error conditions alert(error.message); }); And this is the execution result: {“error”:{“code”:”0x0″,”message”:”The query parameter $select is not supported”,”innererror”:{“message”:”The query parameter $select is…